Home > Card Reader > Ubuntu Smart Card Reader

Ubuntu Smart Card Reader

Contents

The certificates that require installation are the following DOD CA-27 through DOD CA-32, DOD EMAIL CA-27 through DOD EMAIL CA-34, DOD EMAIL CA-39 through DOD EMAIL CA-44, DOD ID CA-33 through This can be done a number of ways, but this is how I did it: Code: sudo mkdir /usr/lib64 Once this is done, the 64-bit version can be installed as described If nothing works right away, try restarting firefox. For what it's worth this has worked flawlessly for me in 13.04. http://easygiftsoftware.com/card-reader/smart-card-reader-software-for-windows-7.html

This is on a fresh install of Mint 15/Firefox 21.I know this has been asked and answered all over the internet. US government smartcards may also need support for the Government Smartcard Interoperability Specification (GSC-IS) v2.1 or newer. Kubuntu worked fine, except the native Coolkey package doesnt support the new PIV identity certifications that the DoD uses through the GUI. First, it's prudent to make sure your card reader is talking to the operating system.

Ubuntu Smart Card Reader

Should I tell him? Idiom for making others feel bad to make myself feel good? Better to get a supported reader. The top level certificate signs the intermediate certificate and the intermediate certificate signs the site's certificate in most cases.

You didn't mention if you installed the DoD certificates, but you're following the instructions as posted on the Ubuntu CAC page, so I'm assuming you did. Anyway, with this, I can get something with openct-tool: $ openct-tool list 0 OMNIKEY CardMan 2020/6020/6120 I've put in a simple EEPROM card and it senses this card, but I can't Tango Icons Tango Desktop Project. Cackey Download You'll get errors like token unavailable.

This module has a broader feature set than CoolKey or CACkey and you are able to access your PIV certificate for those individuals that are Dual Persona. Packages available through openSUSE In order to use the DoD CAC you must install the the following packages: pcsc-lite - PCSC Smart Cards Library http://software.opensuse.org/package/pcsc-lite pcsc-ccid - generic USB CCID (Chip/Smart Common ingredient to thicken the soup Unshorten Google Links What reasons may Donald Trump have had for firing FBI Director James Comey? This process may need to be tweaked for your needs../boostrap./configure --prefix=/usr --sysconfdir=/etc/openscmakesudo checkinstallsudo chown *.deb7.

The below outline describes the process of accessing Enterprise Email and installing the necessary drivers and software to access Enterprise Email and a variety of other secure military websites. Cackey Download Ubuntu No UI is provided to install PKCS11 modules. However, I'm trying to setup Firefox so that I can access PKI-enabled websites and check my .mil email. NSS Internal PKCS #11 Module slots: 2 slots attached status:loaded slot: NSS Internal Cryptographic Services token: NSS Generic Crypto Services slot: NSS User Private Key and Certificate Services token: NSS Certificate

Coolkey Linux

Enjoy. Both of which are the exact same thing, except the "Keyboard" variant is in permanently attached to a USB keyboard (as in, in the same case). Ubuntu Smart Card Reader Step 5: Get and install the driver I traded in the (unsupported) ActivCard for an SCM SCR-3310, for which there are Linux drivers here: https://alioth.debian.org/frs/?group_id=30105 Additionally you can download the Dod Configuration Extension For Firefox This number is unique to your card.

Here's your forge.mil shopping list: the latest version of cackey the latest version of the DoD Configuration extension for Firefox I recommend stashing these two on Dropbox somewhere, just to make check over here Step 7: Set up the browser Now, this depends on the browser. If you have previously used the CACkey module for accessing the Defense Travel System and now use Coolkey, you will have to edit the configuration file: $HOME/.DBsign/UWC/DBsign.cfg Alter the line that Reason: A short general article about Smartcards (or Smartcard readers) is lacking. Pcsc-lite Ubuntu

NOTE: If you are updating from an existing install, or are having issues getting Firefox to play nice when trying to login in with CAC, you may need to remove all This change has led to a great deal of access issues either due to a navigation issue from the AKO website or security software not being properly configured. Eventually, it tries all USB devices and does nothing after that.) I'd like some advice what I should do now? his comment is here You can thus use the LPS ISO to "bootstrap" a computer without any other computer that can use a CAC or trusting anyone except the spi.dod.mil site.

Firefox Browser Configuration Then in a Firefox web browser session, navigate to the following URL and read the instructions within to install the DoD Root Certificates Instructions and DoD Root Certificate Linux Smart Card Tools Unzip the DoD PKI zip 4. Overwhelmingly, the first thing most users need is PKI authentication.

If you get another x.509 format like .pfx, you can use openssl to change it to .pem.

Top macdroid9000 Level 1 Posts: 3 Joined: Fri Jun 26, 2015 8:28 am Re: adding a smart card reader Quote Postby macdroid9000 » Wed Jul 01, 2015 9:52 pm I know Posted by Andy L at 12:38 PM 2 comments: Amarjeet said... Run pcsc_scan and look for the line that says "ATR: XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX". Forge.mil Cackey Configure browser 1.

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed A machine with working CAC authentication is required for the DISA download. UNIX is a registered trademark of The Open Group. weblink The command to use is sudo mkdir /usr/lib64 .

Since it uses a serial port connection, you must tell pcscd where it is located. I get a error that says the cert is invalid and will not be imported.

Top